Integration

Talkdesk iOS Mobile SDK is available through CocoaPods, the largest Cocoa dependency manager.

Installing CocoaPods

If you’re not using CocoaPods, you can follow these instructions to get it running.

If you need to know more about CocoaPods check CocoaPods Getting Started or Using CocoaPods.

Including the Talkdesk SDK Pod

To include the latest version of Talkdesk’s iOS SDK, and add the following line to your Podfile:

pod 'TalkdeskSDK'

Below you can find a complete example of a possible Podfile:

platform :ios, '11.0'
use_frameworks!

target 'MyApp' do
  pod 'TalkdeskSDK'
end

After this, open a shell, navigate to the project’s folder and run the following command:

pod install

Upgrading the SDK version

If you’re not pinning the SDK version you can simply update the Pods when a new Talkdesk SDK version is released. Execute the following command in a shell on the project’s folder:

pod update

If you’re not pinning the SDK version your SDK pod line in the Podfile looks like this:

pod 'TalkdeskSDK'

Using an older SDK version

Note: We recommend always using the latest SDK version as we are constantly improving it.

If you really need to use an older SDK version you can specify the version in the Podfile. See an example below:

pod 'TalkdeskSDK', '~> 0.4.2'